Вопрос по информатике:
Написать программу, которая выводит на экран значения элементов массива в обратном порядке. В массиве 10 элементов, массив заполняется с помощью случайных чисел из интервала (0, 100). (Паскаль)
- 01.04.2015 02:39
- Информатика
- remove_red_eye 16163
- thumb_up 33
Ответы и объяснения 2
Program Massiv2;
Uses Crt;
var a:array[1..10] of integer;
i:integer;
begin
clrscr;
randomize;
for i:=1 to 10 do a[i]:=random(100)+1;
write('Массив в обратном порядке: ');
for i:=10 downto 1 do write(a[i],' ');
readkey;
end.
- 02.04.2015 12:21
- thumb_up 10
Вот программа на C, выводит массив в прямом и обратном порядке:
#include
#include
void func(int *array, int n, int i)
{
if (i < n) {
array[i] = 0 + rand() % 100;
printf("%d ", array[i]);br /> func(array, n, i + 1
- 03.04.2015 20:31
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.