Вопрос по информатике:
1. Написать программу, которая подсчитывает количество четных чисел в массиве целых чисел. Количество элементов массива равно N.
- 12.01.2018 09:39
- Информатика
- remove_red_eye 14541
- thumb_up 82
Ответы и объяснения 2
Решение на языке C:
#include
int func(int *array, int n)
{
int result = 0;
for (int i = 0; i < n; i++) {
if (array[i] % 2 == 0) {
result++;
}
}
return result;
}
int main(int argc, char *argv)
{
int array[] = {1, 2 , 3 , 4 , 5 , 6, 7, 46};
printf("%d", func(array, 8));br /> return
- 13.01.2018 05:07
- thumb_up 6
// Язык Паскаль
Program Massiv;
Uses Crt;
const n=10; // Нужно больше сам подставишь нужное число
var a:array[1..n] of integer;
i,c:integer;
begin
clrscr;
write('Введите элементы массива: ');
c:=0;
for i:=1 to n do
begin
readln(a[i]);
if (a[i] mod 2)=0 then c:=c+1;
end;
writeln;
write('Исходный массив:');
for i:=1 to n do write(a[i],' ');
writeln('Количество чётных элементов: ',c);
readkey;
end.
- 14.01.2018 10:51
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.