Вопрос по информатике:
Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью v километров в час. На какой отметке он остановится через t часов?
Программа получает на вход значение v и t. Если v0, то Вася движется в положительном направлении по МКАД, если же значение v0, то в отрицательном.
Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася.
- 18.11.2017 11:03
- Информатика
- remove_red_eye 12000
- thumb_up 69
Ответы и объяснения 1
Решение на pascal. Могут быть небольшие недочёты =)
Program avtorMaltsevaDY;
var
s, t, v, z :integer;
begin
s:=109;
writeln ('Vvedite vremya');
readln (t);
writeln ('Vvedite scorost');
readln (v);
z:=v*t;
if z>0 then
while z
z:=z-s;
end;
else
while (z>0) and (z
z:=z+s;
end;
Writeln ('Vasya ostanivitsya na otmetke - ', z);
end.
- 19.11.2017 08:47
- thumb_up 30
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.