Вопрос по информатике:
по введённому номеру года выдать какой это год по восточному календарю.плиз ответьте развёрнуто и понятно.нужно написать в программе паскаль
- 31.01.2017 22:38
- Информатика
- remove_red_eye 11422
- thumb_up 66
Ответы и объяснения 1
Начало отсчета лет - 1984 год. Надо написать программу (pascalABC). Вводите год, нужный вам, отнимаете от него 1984 и находите остаток от деления на 12. Последовательность животных в 12-летнем цикле - крыса, корова, тигр, заяц, дракон, змея, лошадь, овца, обезьяна, курица, собака, свинья. То есть если при делении на 12 остаток равен 0, значит введенный год - год крысы, если 1 - год коровы и т.д.
Программа:
var a,b,c:longint;
begin
write('Введите год: ');
readln(a);
c:=a-1984;
b:=c mod 12;
case b of
0:writeln(a,' - год крысы');
1:writeln(a,' - год коровы');
2:writeln(a,' - год тигра');
3:writeln(a,' - год зайца');
4:writeln(a,' - год дракона');
5:writeln(a,' - год змеи');
6:writeln(a,' - год лошади');
7:writeln(a,' - год овцы');
8:writeln(a,' - год обезьяны');
9:writeln(a,' - год курицы');
10:writeln(a,' - год собаки');
11:writeln(a,' - год свиньи');
end;
end.
- 02.02.2017 07:25
- thumb_up 52
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.