Вопрос по информатике:
Составить программу, которая в последовательности целых чисел находит сумму чисел кратных 7 в диапозоне от 6 до 80. Программа получает на вход целые числа, кол-во не известно, 0-признак окончания
Входные данные: -7,14,84,0
Составить по Паскалю
- 01.04.2015 13:36
- Информатика
- remove_red_eye 17787
- thumb_up 32
Ответы и объяснения 1
programm p;
var
a:array[1..100 ] of integer;
i,n:integer;
s:integer;
begin
readln n;
for i:=1 to n do
readln(a[i]);
s:=0;
for i:=1 to n do
begin
if (a[i]>5)and(a[i]<81)and(a[i]/7=int a[i]/7) then
s:=s+a[i];
if a[i]= 0 then break;
end;
writeln(s);
end.
- 02.04.2015 01:29
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.