Вопрос по информатике:
Написать программу. Задано натуральное число. Определить делится ли оно на два. Примечание: проверка делимости на 2 осуществляется следующим образом: пусть N-натуральное число. Если N/2=N\2,то число делится на 2, иначе нет. (N/2-обычное деление, N\2-деление нацело)
- 09.12.2017 11:24
- Информатика
- remove_red_eye 1957
- thumb_up 68
Ответы и объяснения 1
вообще признак делимости на 2 можно определить проще. Если остаток от деления на 2=0 тогда число делится на 2 нацело иначе нет if (n mod 2)=0 then writeln('Число делится на 2 нацело' ) else writeln('Число не делиться на 2 нацело' );
Однако если по условию задачи признак, такой то уж ничего не пделаешь
Program evenNum;
Uses crt;
var n:real;
begin
clrscr;
write('Введите число n: ');
readln(n);
if ((n/2)(n div 2)) then writeln('Число не делится на 2 нацело' )
else writeln('Число делится на 2 нацело' );
readkey;
end.
;- 09.12.2017 14:56
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.