Вопрос по информатике:
Написать программу, которая в зависимости от введенного количества минут (M <= 60) будет подставлять слово минута в нужном падеже
Например, 25 минут
31 минута
53 минуты
(используя оператор CASE и операции DIV и MOD)
- 26.09.2018 21:57
- Информатика
- remove_red_eye 8353
- thumb_up 133
Ответы и объяснения 1
var
M:byte;
begin
write('M = '); readln(M);
case M div 10 of
1: writeln(M, ' минут');
else
case M mod 10 of
0, 5..9: writeln(M, ' минут');
1: writeln(M, ' минута');
2..4: writeln(M, ' минуты');
end;
end;
end.
- 27.09.2018 19:52
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.