Вопрос по информатике:
Написать программу для вычисления дискриминанта d квадратного уравнения ax2 + bx + c = 0. Разработать тесты проверки правильности работы программы для вариантов, когда d>0, d=0 и d<0.
- 20.12.2017 18:19
- Информатика
- remove_red_eye 20397
- thumb_up 62
Ответы и объяснения 1
Выложу решение полного уровнения.
var a,b,c,d:integer; x1,x2:real;
begin
writeln('Введите коэффициенты');
readln(a,b,c);
d:=b*b-4*a*c;
if (d<0) then writeln('Нет решения')
else if (d=0) then
begin
x1:=-b/(2*a);
writeln('x=',x1);
end
else begin
x1:=(-b+sqrt(d))/(2*a);
x2:=(-b-sqrt(d))/(2*a);
writeln('x1= ',x1,'x2=',x2);
end;
readln
end.
- 21.12.2017 06:15
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.