Вопрос по информатике:
нужно написать программу для нахождения суммы цифр любого трехзначного числа, вводимого с клавиатуры во время работы программы)) как это сделать с помощью mod или div без цикла???
- 03.06.2018 09:16
- Информатика
- remove_red_eye 14169
- thumb_up 61
Ответы и объяснения 1
var
summ, c:integer;
begin
write('Введите число '); readln(c);
summ := c mod 10 + (c div 10) mod 10 + c div 100;
writeln('Сумма цифр числа ', c , ' равна ', summ);
end.
- 04.06.2018 09:34
- thumb_up 19
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.