Вопрос по информатике:
Напишите программу, которая генерирует 10 случайных чисел в диапазоне от 1 до 20, выводит эти числа на экран и вычисляет их среднее арифметическое
- 12.02.2018 21:05
- Информатика
- remove_red_eye 3858
- thumb_up 104
Ответы и объяснения 2
const
n = 10;
var
a, summ, i:integer;
begin
randomize;
summ := 0;
for i := 1 to n do
begin
a := random(20) + 1;
summ := summ + a;
write(a, ' ');
end;
writeln;
writeln('Среднее арифметическое этих чисел ',summ / n);
end.
- 13.02.2018 19:15
- thumb_up 17
program random_1;
var
x,sum,i:integer;
begin
randomize;
writeln('Ряд случайных чисел: ');
for i:=1 to 10 do begin
x:=random(20)+1;
sum:=sum+x;
if i10 then write(x,', ')
else writeln(x,'.');
end;
writeln('Среднее арифметическое этих чисел ',sum/10);
end.
- 14.02.2018 16:35
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.