Вопрос по информатике:
Пк запрашивает название и радиусы орбит двух планет (в миллионах км) и скорости движения орбит (в миллионах км в сутки). Вычислить продолжительность года на планетах (длина орбит/скорость). Результаты должны иметь вид:
Продолжительность года на планете <имя1> суток;
Продолжительность года на планете <имя2> суток;
Помогите составить программу в Pascal.
- 04.02.2018 00:16
- Информатика
- remove_red_eye 6698
- thumb_up 61
Ответы и объяснения 2
Program Planet;
var
R1, R2, l1, l2, v1, v2, time1, time2 : real;
c, b : string;
begin
Write('Планета1-');
Readln(b);
Write('Планета2-');
Readln(c);
Write('R1=');
Readln(R1);
Write('R2=');
Readln(R2);
Write('v1=');
Readln(v1);
Write('v2=');
Readln(v2);
L1:=2*Pi*R1;
L2:=2*Pi*R2;
Time1:=l1/v1;
Time2:=l2/v2;
Writeln('Продолжительность года на пленете ',b,'= ', Time1:0:2, ' суток');
Writeln('Продолжительность года на пленете ',c,'= ', Time2:0:2, ' суток');
end.
как-то так)
- 05.02.2018 04:33
- thumb_up 26
var
r1,r2,v1,v2:integer;
name1,name2:string;
begin
writeln ('Введите название двух планет');
readln (name1,name2);
writeln ('Введите радиусы двух планет');
readln (r1,r2);
writeln ('Введите скорости движения орбит');
readln (v1,v2);
writeln ('Продолжительность года на планате ',name1,'=', r1/v1);
writeln ('Продолжительность года на планате ',name2,'=', r2/v2);
end.
- 06.02.2018 20:39
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.