Вопрос по информатике:
Составьте программу нахождения наибольшего общего делителя трех чисел, используя следующую формулу:
НОД(А, B, С) = НОД(НОД(A, В), С).
Испоьзуя алгоритм Евклида
- 24.07.2015 16:34
- Информатика
- remove_red_eye 7141
- thumb_up 35
Ответы и объяснения 1
Var
a, b, c: longint;
function nod(a, b: longint): longint;
begin
a := abs(a);
b := abs(b);
if a * b = 0 then nod := 1
else begin
while a b do
if a > b then
a := a - b
else
b := b - a;
nod := a;
end;
end;
begin
read(a, b, c);
writeln(nod(nod(a, b), c));
end.
- 25.07.2015 00:48
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.