Вопрос по информатике:
Помогите, пожалуйста, написать программу(паскаль). С пояснениями, желательно.
Нужно с for.
Найти сумму всех n-значных чисел, кратных k.(1 <(или равно) n<(или равно)4).
- 09.04.2015 22:11
- Информатика
- remove_red_eye 13528
- thumb_up 16
Ответы и объяснения 2
program sada;
var k,n,res,i:integer;
temp:string;
begin
res:=0;
readln(k);
temp:='';
for i:=1 to n do
temp:=temp+'9';
n:=strtoint(temp);
for i:=1 to n do begin
if (i mod k = 0) then res:=res+i;
end;
writeln(res);
end.
p.s. Программа написана на pascalABC
- 11.04.2015 15:05
- thumb_up 34
var
k, n, Summ, i, max, min:integer;
begin
write('n = '); readln(n);
write('k = '); readln(k);
max := 9;
min := 1;
for i := 2 to n do
begin
max := max * 10 + 9;
min := min * 10;
end;
for i := min to max do
if i mod k = 0 then
Summ := Summ + i;
writeln('Сумма = ', Summ);
end.
- 12.04.2015 12:11
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.