Вопрос по информатике:
составить программу,которая определяет сколько раз встречается в таблице а максимальное по величине число.Pascal.Массивы.Помогите,пожалуйста
- 26.09.2015 19:06
- Информатика
- remove_red_eye 19658
- thumb_up 45
Ответы и объяснения 1
const n=100;
m=100;
var A: array[1..n,1..m] of integer;
i,j,maxi,maxj,k: integer;
begin
randomize;
for i := 1 to n do begin
for j := 1 to m do begin
A[i,j] := random(100);
end;
end;
maxi := 1;
maxj := 1;
for i := 1 to n do begin
for j := 1 to m do begin
if (A[i,j] > A[maxi,maxj]) then begin
maxi := i;
maxj := j;
end;
end;
end;
k := 0;
for i := 1 to n do begin
for j := 1 to m do begin
if (A[i,j] == A[maxi,maxj]) then k := k + 1;
end;
end;
writeln('k = ', k);
end.
- 27.09.2015 14:40
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.