Вопрос по информатике:
Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение
- 12.05.2018 23:19
- Информатика
- remove_red_eye 14323
- thumb_up 51
Ответы и объяснения 1
var
m: array [1..10] of integer;
max, k, i: integer;
begin
for i := 1 to 10 do
read(m[i]);
max := m[1];
k := 1;
for i := 2 to 10 do
if m[i] > max then
begin
k := 1;
max := m[i]
end
else
if m[i] = max then
inc(k);
write(k)
end.
- 14.05.2018 14:18
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.