Вопрос по информатике:
1)дано целое число N(больше 0). Найти сумму 1+1/2+1/3.....1/N(вещественное число). Входные данные: ввести целое числоN(1<=n<=20)
Выходные данные: вывести сумму 1+1/2=1/3+.....1N с точностью до 4 цифр в дробной части.( в паскале)
- 13.07.2018 02:17
- Информатика
- remove_red_eye 7369
- thumb_up 64
Ответы и объяснения 1
var H: real;
N, i: integer;
begin
H := 0;
readln(N);
for i := 1 to N do
H := H + 1/i;
writeln(H:6:4)
end.
- 14.07.2018 04:09
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.