Вопрос по информатике:
напишите программу для паскаля.
условие: обменять значения двух переменных, используя третью(буферную) переменную
- 08.02.2018 12:31
- Информатика
- remove_red_eye 8932
- thumb_up 92
Ответы и объяснения 1
var
a, b, buf:real;
begin
write('a = '); readln(a);
write('b = '); readln(b);
buf := a;
a := b;
b := buf;
writeln('a = ', a);
writeln('b = ', b);
end.
// без буферной переменной
var
a, b:real;
begin
write('a = '); readln(a);
write('b = '); readln(b);
a := a + b;
b := a - b;
a := a - b;
writeln('a = ', a);
writeln('b = ', b);
end.
- 08.02.2018 23:11
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.