Вопрос по информатике:
Составьте программу нахождения наибольшего значения роста у двух членов школьной баскетбольной команды (рост спортсменов вводится с клавиатуры).
- 09.09.2018 07:09
- Информатика
- remove_red_eye 14628
- thumb_up 101
Ответы и объяснения 1
Uses
Crt;
Var
i, N, kol: byte;
sum_rost, sr_rost: real;
team: array[1..100] of real;
Begin
sum_rost := 0.0;
sr_rost := 0.0;
kol := 0;
write('Введите количество членов команды');
read(N);
writeln('Введите рост каждого члена команды');
for i := 1 to N do
begin
readln(team[i]);
sum_rost := sum_rost + team[i];
end;
sr_rost := sum_rost / N;
for i := 1 to N do
if (team[i] > sr_rost) then
kol := kol + 1;
writeln('Количество членов команды, рост которых превышает средний по команде (', sr_rost:4:2, ')');
write(' равно ', kol);
End.
Прошу. Я надеюсь надо было на паскале написать?)
- 09.09.2018 10:40
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.