Вопрос по информатике:
Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры. вид экрана: Введите числа. Для завершения последовательности нажмите ноль. 45 23 15 0 введено чисел:3 сумма чисел:83 Среднее арифметическое:27.67 С ЦИКЛОМ While do пожалуйста напишите а не с Repeat untill
- 20.02.2018 09:53
- Информатика
- remove_red_eye 11135
- thumb_up 56
Ответы и объяснения 2
program z8;
uses crt;
var
i,k,n:byte;
s:integer;
sa:real;
begin
clrscr; i:=1;
writeln('Для завершения последовательности нажмите ноль');
while i>0 do begin
read(i);
write(' '); {- нужен, чтобы числа нормально смотрелись}
if i>0 then begin
k:=k+1;
s:=s+i;
end; end;
sa:=s/k;
write('введено чисел:',k,' сумма чисел:',s,'Среднее арифметическое:',sa:4:2);
readkey
end.
- 21.02.2018 21:45
- thumb_up 5
uses crt;
var a,n,s,ar:real;
begin
a:=1;
n:=-1;
s:=0;
writeln('Введите последовательность чисел: ');
while a0 do begin
read(a);
n:=n+1;
s:=s+a;
end;
ar:=s/n;
writeln('Введено чисел: ',n);
writeln('Сумма чисел: ',s);
writeln('Среднее арифметическое: ',ar);
end.
- 22.02.2018 19:58
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.