Вопрос по информатике:
Помогите решить, очень нужно...
2. Составьте блок-схему алгоритма(её не надо) и программу вычисления в массиве A(10) количества положительных элементов.
3. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.
- 25.04.2016 06:07
- Информатика
- remove_red_eye 5780
- thumb_up 34
Ответы и объяснения 1
2)
Program Massiv1;
var a:array[1..10] of real;
i:integer;
s:real;
begin
clrscr;
write('Введите элементы массива: ');
s:=0;
for i :=1 to 10 do
begin
readln(a[i]);
if (a[i]>0) then s:=s+1;
end;
writeln;
for i :=1 to 10 do writeln(a[i]:3:3);
writeln('Количество положительных элементов:',s);
readkey;
end.
3)
Program Massiv2;
var a:array[1..10] of integer;
i,b:integer;
begin
clrscr;
b:=2;
for i :=1 to 10 do
begin
a[i]=i+b;
b:=b+1;
write(a[i]:2);
end;
readkey;
end.
- 25.04.2016 22:37
- thumb_up 32
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.