Вопрос по информатике:
Сформируйте массив, содержащий 15 элементов, с помощью датчика случайных чисел. Получите новый массив, каждый элемент которого равен удвоенному соответствующему элементу исходного массива . В полученном массиве найдите максимальный элемент среди элементов, номера которых кратны трем. Выведите на экран исходные и полученные результаты.
- 14.01.2018 10:43
- Информатика
- remove_red_eye 3208
- thumb_up 97
Ответы и объяснения 1
const N=15
var a: array |1...N| of integer;
i,m,n :integer;
begin
for i:=1 to N do readln (a|i|);
m:=0
for i:=1 to N do begin
a|i|:=a|i|*2;
end;
for i:=1 to N do
if (i mod 3=0) and ((a|i|>m)or (m=0)) then
m:=a|i|;
writeln (m);
end.
- 15.01.2018 02:47
- thumb_up 9
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.