Вопрос по информатике:
Составьте программу вычисления в массиве A(N) произведения четных элементов.
- 13.09.2017 01:09
- Информатика
- remove_red_eye 18481
- thumb_up 49
Ответы и объяснения 2
program csdnciuo;
uses crt;
'var a:array [1..100] of integer;
i,p,n:integer;
begin
clrscr;
readln(n);
for i:=1 to n do
readln(a[i]);
p:=1;
for i:=1 to n do
if a[i] mod 2 =0 then p:=p*a[i];
writeln(p);
readln;
end.
- 14.09.2017 18:59
- thumb_up 65
var
a: array [1..100] of integer;
i, p, n: integer;
begin
p := 1;
read(n);
for i := 1 to n do
begin
read(a[i]);
if a[i] mod 2 = 0 then
p := p * a[i];
end;
writeln(p);
end.
- 15.09.2017 06:53
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.