Вопрос по информатике:
1) Дан одномерный массив из 12 элементов. Составить программу заполняющую массив целыми числами в интервале -20 до 15
2)Требуется подсчитать кол-во пятерок , четверок, тоек полученных за контрольную работу, если число учеников равно 8
3)Дан одномерный числовой массив,изменить знак элементов массива К[1;12] на противоположный
- 26.12.2017 03:39
- Информатика
- remove_red_eye 995
- thumb_up 11
Ответы и объяснения 1
var
a:array[1..12] of integer;
i:integer;
begin
randomize;
writeln('Сгенерированный массив:');
for i := 1 to 12 do
begin
a[i] := random(36) - 15;
write(a[i], ' ');
end;
writeln;
end.
//вторая программа
const
n = 8;
var
a:array[1..n] of integer;
i, count3, count4, count5:integer;
begin
randomize;
writeln('Оценки учеников:');
for i := 1 to n do
begin
a[i] := random(3) + 3;
write(a[i], ' ');
if a[i] = 5 then
inc(count5);
if a[i] = 4 then
inc(count4);
if a[i] = 3 then
inc(count3);
end;
writeln;
writeln('Троек - ', count3);
writeln('Четверок - ', count4);
writeln('Пятерок - ', count5);
end.
//третья программа
var
k:array[1..12] of integer;
i:integer;
begin
randomize;
writeln('Сгенерированный массив:');
for i := 1 to 12 do
begin
k[i] := random(36) - 15;
write(k[i], ' ');
end;
writeln;
writeln('Преобразованный массив:');
for i := 1 to 12 do
begin
k[i] := k[i] * (-1);
write(k[i], ' ');
end;
end.
- 27.12.2017 04:11
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.