Вопрос по информатике:
Напишите программу, которая выводит на экран числа в указанном виде. Пример для n=6:
1
1 2
1 2 3
1 2 3 4
1 2 3 4 5
1 2 3 4 5 6
почему не получается вот программа
program qq1;
var n,i,j:integer;
begin
writeln(' введите значение n:');
readln(n);
for i:=1 to n do begin
for j:=1 to i do write(j-i,'');
writeln();
end;
end.
- 17.05.2016 02:47
- Информатика
- remove_red_eye 19463
- thumb_up 25
Ответы и объяснения 1
program qq1;
var n,i,j:integer;
begin
writeln(' введите значение n:'');
readln(n);
for i:=1 to n do begin
for j:=1 to i do write(j,' '); //тут заменил j - i на j и в ковычках добавл пробел
writeln();
end;
end.
- 18.05.2016 00:35
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.