Вопрос по информатике:
Написать программу Заполнить массив из 15 элементов случайными числами (-20;80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов
- 13.03.2017 02:43
- Информатика
- remove_red_eye 17726
- thumb_up 65
Ответы и объяснения 1
const
n = 15;
var
a:array[1..n] of integer;
i, Count, Summ:integer;
begin
randomize;
Count := 0;
Summ := 0;
for i := 1 to n do
begin
a[i] := random(101) - 20;
write(a[i], ' ');
inc(Summ, a[i]);
if a[i] < 0 then
inc(count);
end;
writeln;
writeln('Summ = ', Summ);
writeln('Count = ', count);
readln;
end.
- 14.03.2017 01:05
- thumb_up 76
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.