Вопрос по информатике:
Паскаль.1)Определите, сколько чисел, введённых пользователем делятся на 3 без остатка. Ввод чисел пользователем заканчивается после ввода цифры 0. 2)Найдите сумму цифр числа, меньших 5. Например, для числа 715245 это будет 1+2+4=7. Написать блок-схему и программу.
- 19.12.2016 16:38
- Информатика
- remove_red_eye 13201
- thumb_up 73
Ответы и объяснения 2
1)
program ABC;
var num,count:integer;
begin
readln(num);
while num0 do
begin
if (num mod 3) = 3 then
count:=count+1
end;
writeln(count)
end.
2)
program ABC;
var num,sum:integer;
begin
readln(num);
while num0 do
begin
if (num mod 10) < 5 then
sum:=sum+num mod 10;
num:= num div 10
end;
writeln(sum)
end.
- 20.12.2016 02:33
- thumb_up 52
var
C,count:integer;
begin
write('Введите число ');
count := 0;
readln(C);
while C 0 do
begin
if (C mod 3) = 0 then
inc(count);
write('Введите число ');
readln(C);
end;
writeln('Count = ',count);
readln;
end.
//вторая программа
var
C, Summ:integer;
begin
write('C = ');
Summ := 0;
readln(C);
while C 0 do
begin
if (C mod 10) < 5 then
inc(Summ, C mod 10);
C := C div 10;
end;
writeln('Summ = ',Summ);
readln;
end.
- 21.12.2016 18:59
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.