Вопрос по информатике:
Задача №1Составить программу проверяющую является ли слово "перевертышем"
Задача №2Подсчитать каких букв в предложении больше "а" или "е"
все в паскале
- 01.04.2018 16:49
- Информатика
- remove_red_eye 12072
- thumb_up 90
Ответы и объяснения 1
var
S:string;
i:integer;
begin
write('S = ');
readln(S);
for i := 1 to Length(S) do
if S[i] S[Length(S) - i + 1] then
begin
writeln('No');
readln;
Exit;
end;
writeln('Yes');
readln;
end.
//вторая программа
var
S:string;
i, countA, countE:integer;
begin
CountA := 0;
CountE := 0;
write('S = ');
readln(S);
for i := 1 to Length(S) do
if S[i] = 'a' then
inc(countA)
else
if S[i] = 'e' then
inc(countE);
if countA > countE then
writeln('a > e')
else
if countA < countE then
writeln('a < e')
else
writeln('a = e');
readln;
end.
- 02.04.2018 07:25
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.