Вопрос по информатике:
Паскаль АВС: написать программу вывод простых чисел, с помощью массива.
- 09.03.2018 14:03
- Информатика
- remove_red_eye 14073
- thumb_up 65
Ответы и объяснения 1
var
P:array[2..100000] of boolean;
i, n, pr:integer;
flag:boolean;
begin
write('max = ');
readln(n);
for i := 2 to n do
P[i] := true;
pr := 2;
flag := true;
while flag do
begin
i := 2 * pr;
while i <= n do
begin
P[i] := false;
i := i + pr;
end;
flag := false;
for i := pr + 1 to n do
if P[i] then
begin
pr := i;
flag := true;
break;
end;
end;
for i := 10 to n do
if P[i] then
writeln(i);
readln;
end.
- 09.03.2018 17:18
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.