Вопрос по информатике:
составьте программу дискриминанта так, чтобы а,b,с -задавались генератором случайных чисел (random);+эта программа должна включать в себя массив ( в Pascal )
Просьба писать по возможности с объяснением)
- 20.07.2015 09:19
- Информатика
- remove_red_eye 18817
- thumb_up 34
Ответы и объяснения 1
Var koef:array[1..3] as integer;
d:real;
i:integer;
Begin
Randomize;
;Генерируем коэффициенты a b c
for i:=1 to 3 do
begin
koef[i]:=random(100);
end;
;Считаем дискриминант
d:=koef[2]*koef[2]-4*koef[1]*koef[3];
;выводим ответ
Writeln(d:5:2);
end.
- 21.07.2015 10:42
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.