Вопрос по информатике:
1.Составить программу, которая увеличивает каждый элемент настоящей таблице х [1 .. 10] на 1.
2. составить программу, замены положительных элементов настоящей таблице х [1 .. 10] на 0.
3.составить программу, замены отрицательного элементов настоящей таблице х [1 .. 10] на их квадрат.
4.составить прогрумму, которая увеличивает на 2 все элементы настоящей таблице х [1 .. 10], которые больше 10.
- 14.08.2018 13:04
- Информатика
- remove_red_eye 4840
- thumb_up 56
Ответы и объяснения 1
//первая программа
var
x:array[1..10] of integer;
i:integer;
begin
for i := 1 to 10 do
begin
write('x[', i, '] = ');
readln(x[i]);
inc(x[i]);
end;
writeln;
writeln('Result');
for i := 1 to 10 do
write(x[i], ' ');
readln;
end.
//вторая программа
var
x:array[1..10] of integer;
i:integer;
begin
for i := 1 to 10 do
begin
write('x[', i, '] = ');
readln(x[i]);
if x[i] > 0 then
x[i] := 0;
end;
writeln;
writeln('Result');
for i := 1 to 10 do
write(x[i], ' ');
readln;
end.
// третья программа
var
x:array[1..10] of integer;
i:integer;
begin
for i := 1 to 10 do
begin
write('x[', i, '] = ');
readln(x[i]);
if x[i] < 0 then
x[i] := x[i] * x[i];
end;
writeln;
writeln('Result');
for i := 1 to 10 do
write(x[i], ' ');
readln;
end.
// четвертая программа
var
x:array[1..10] of integer;
i:integer;
begin
for i := 1 to 10 do
begin
write('x[', i, '] = ');
readln(x[i]);
if x[i] > 10 then
x[i] := x[i] + 2;
end;
writeln;
writeln('Result');
for i := 1 to 10 do
write(x[i], ' ');
readln;
end.
- 15.08.2018 01:22
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.