Вопрос по информатике:
Температура в градусац Цельсия изменяется от 0 до 100 с шагом 5. Написать программу перевода температуры из градусов Цельсия в градусы Фаренгейта(F). Формула перевода: F=1.8+32.
- 18.08.2017 15:35
- Информатика
- remove_red_eye 3551
- thumb_up 71
Ответы и объяснения 2
программа на паскале
var a: array [1..21,1..2] of real;
i:integer;
begin
a[1,1]:=0.0 ;
for i:=2 to 21 do
a[i,1]:=a[i-1,1]+5;
for i:=1 to 21 do
a[i,2]:=a[i,1]*1.8+32.0;
for i:=1 to 21 do
writeln (a[i,1]:3:0,' celcia = ',a[i,2]:3:0,' farrengeit');
readln;
end.
- 19.08.2017 10:26
- thumb_up 48
Program C2F;
Uses
Crt;
Var i: integer;
c,f: real;
Begin
ClrScr; {очистить экран}
Writeln('From Celsius to Fahrenheit:');
Write('Type temperature (in celsius): '); read(c);
f := 32 + 2*c * (1 - 1/10);
Writeln('Temperature in fahrenheit: ', f:3:3);
{ :3:3 - общее количество знаков и знаков после запятой }
Writeln(' Celsius to Fahrenheit from 0 to 100, step 5: ');
i := 0;
While i <= 100 Do
Begin
f := 32 + 2*i * (1 - 1/10);
Writeln(' C = ',i:3,' | F = ', f:3:3);
i := i + 5;
End;
Readkey; {чтоб не нажимать alt+f5 для просмотра результатов}
End.
- 20.08.2017 00:00
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.