Вопрос по информатике:
составить программу на ЯП Паскаль, которая бы при помощи генератора СЧ [напомню, это ф-ции randomize и random(i)] позволяла бы сыграть с ПК в игру «угадай число» при помощи виртуальной игральной кости. Счёт ведётся до 10 набранных очков. Если угадал – плюс одно очко, не угадал – счёт не меняется. Счет вести и для игрока и для ПК.
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 01.01.2017 12:23
- Информатика
- remove_red_eye 15526
- thumb_up 77
Ответы и объяснения 1
program game;
var
costi, me, comp, myscore, compscore, round: integer;
begin
randomize;
costi := random(6);
myscore := 0;
compscore := 0;
for round := 1 to 10 do
begin
writeln('Введите ваще число от 1 до 6');
readln(me);
if me = costi then
writeln('Выпало число ', costi, '. Вы угадали, счет становится (', myscore + 1, ';', compscore,')')
else writeln('Выпало число ', costi, '. Вы не угадали, счет остается преждним (', myscore, ';', compscore,')');
if me = costi then myscore := myscore + 1;
writeln('Кости бросает компьютер');
costi := random(6);
comp := random(6);
if comp = costi then
writeln('Выпало число ', costi, '. Компьютер угадал, счет становится (', myscore, ';', compscore + 1,')')
else writeln('Выпало число ', costi, '. Компьютер не угадал, счет остается преждним (', myscore, ';', compscore,')');
if comp = costi then compscore := compscore + 1;
end;
if myscore>compscore then writeln ('Вы победили!');
if myscore
end.
- 02.01.2017 08:20
- thumb_up 76
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.