Вопрос по информатике:
Составьте программу, заменяющую меньшее из двух данных чисел на среднее арифметическое этих чисел,а большее из двух данных чисел на среднюю геометрическую этих чисел help me!!!please
- 08.11.2016 11:50
- Информатика
- remove_red_eye 5840
- thumb_up 44
Ответы и объяснения 1
program lkcfndsl;
uses crt;
var a,b,s,g:real;
begin
clrscr;
readln(a,b);
s:=(a+b)/2;
g:=sqrt(a*b);
if a>b then a:=g else a:=s;
if b>a then b:=g else b:=s;
writeln(a,b);
readln;
end.
Надеюсь так понял.
- 09.11.2016 18:03
- thumb_up 47
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.