Вопрос по информатике:
помогите написать программу которая вычисляет сумму положительных из n введенных с клавиатуры целых чисел
(FOR) В паскале ABC
- 02.01.2018 14:08
- Информатика
- remove_red_eye 15842
- thumb_up 42
Ответы и объяснения 1
program z1; (Начало программы)
var n, s, i, c:integer; (Раздел описания переменных, n(кол-во чисел), s(сумма чисел), i(счетчик), с(число, введенное с клавиатуры))
begin (тело программы)
writeln ('Кол-во чисел?'); (подсказка для пользавателя)
readln (n); (считывание переменной)
s:=0; (обнуляем переменную)
For i:= 1 to n do begin (цикл будет повторяться от 1 до N; т.к в цикле будет несколько действий открываем операторные скобки (begin\end), начало цикла)
writeln ('Введите число'); (подсказка для пользавателя)
readln(c); (считывание переменной)
If c>0 then s:=s+c; (если с>0 тогда к сумме мы прибавляем число)
end; (конец цикла)
writeln ('Сумма=',s); (подсказка для пользавателя и ответ)
readln(s); (считывание переменной)
readln; (считывание)
end.(конец программы)
- 02.01.2018 21:04
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.