Вопрос по информатике:
1)составить программу, которая подсчитает объем любого шара по формуле: V=4/3Пr^3
2)даны действительные числа x и y. необходимо определить принадлежит ли точка с координатами (x,y) окружности с радиусом R и центром в точке (x1,y1).
3)дан одномерный числовой массиф В(16). Необходимо вывести на экран индексы элементов значения, которых равны числу P.
cрочно надо на языке паскаль составить плиз)
- 01.06.2018 14:21
- Информатика
- remove_red_eye 12913
- thumb_up 42
Ответы и объяснения 2
Program Shar;
Var
r, v: Real;
Begin
Write('r = ');
ReadLn(r);
v := 4 / 3 * 3.14 * r * r * r;
WriteLn('v = ', v);
ReadLn;
End.
- 02.06.2018 13:23
- thumb_up 40
1) program ht1;
var v,p,r:real;
begin
p:=3.14;
writeln ('vvedite r');
readln (r);
v:=4/3*p*(r*r*r);
writeln(v);
end.
2) program ht2;
var x,y,r:integer;
begin
writeln('vvedite r);
readln(r);
writeln('vvedite x');
readln (x);
writeln ('vvedite y');
readln (y);
if (x<=r) and (y<=r)
then writeln ('prinadlezhit')
else writeln ('ne prinadlezhit');
end.
3) а в третью я врубиться не могу.
- 03.06.2018 15:20
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.