Вопрос по информатике:
решите какое-либо Задание!!!!!!!!
1.Напишите программу,которая в последовательности целых чисел определяет количество четных отрицаетльных чисел. Программа получает на вход целые числа, количество введеных чисел неизвестно,Последовательность чисел заканчивается числом 0(0- признак окончания ввода,не входит в последовательность.
Количество чисел не превышает 1000.Введеные числа по модулю непревышают 30000.
Программа должна вывести одно число количество четных отрицательных чисел. входные данные -1 7 2 -6 0 выходные данные 1
2 Напишите программу,которая в последовательности целых чисел определяет количество нечетных положительных чисел. Программа получает на вход целые числа, количество введеных чисел неизвестно,Последовательность чисел заканчивается числом 0(0- признак окончания ввода,не входит в последовательность.
Количество чисел не превышает 1000.Введеные числа по модулю непревышают 30000.
Программа должна вывести одно число количество нечетных положительных чисел: -1 7 2 -6 0 выходные данные 1
- 16.10.2017 04:53
- Информатика
- remove_red_eye 16189
- thumb_up 58
Ответы и объяснения 1
1)
Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a0) and (k1<1000) do
Begin
if (a<0) and (a mod 2=0) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end.
2)
Program pr;
uses crt;
Var a,k,k1:integer;
Begin
Writeln('Введите a');
readln(a);
k1:=1;
k:=0;
While (a0) and (k1<1000) do
Begin
if (a>0) and (a mod 20) and (abs(a)<=30000) then k:=k+1;
k1:=k1+1;
readln(a);
end;
Writeln('k=',k);
readln;
end.
- 17.10.2017 13:58
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.