Вопрос по информатике:
помогите пожалуйста решить задачу в паскале:
Составить программу,проверяющую,является ли заданное натуральное число палиндромом,т.е. таким,которое читается одинаково слева направо и справа налево(например:23132).
- 26.02.2015 19:02
- Информатика
- remove_red_eye 17379
- thumb_up 28
Ответы и объяснения 1
var n, m, p: word;
begin
write('Enter number: ');
readln(n);
m := n;
p := 0;
while m > 0 do begin
p := p * 10 + m mod 10;
m := m div 10;
end;
if n = p then
writeln('Palindrome')
else
writeln('Not palindrome');
readln;
end.
- 27.02.2015 13:25
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.