Вопрос по информатике:
Решите в тетради задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности положительных чисел, которые вводятся с клавиатуры
- 11.01.2017 02:42
- Информатика
- remove_red_eye 5063
- thumb_up 67
Ответы и объяснения 1
begin
read(n);
while (n 0) do // пока не равно нулю делать
begin
s := s + n;
k = k + 1;
end.
writeln(s/k); // среднее
writeln(s); // сумма
end.
Переменные сам объяви. s и к должны быть типа real
Если что-то не понятно пиши в ЛС
- 12.01.2017 07:33
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.