Вопрос по информатике:
Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр. Определите, сколько раз каждая гласная буква встречается в тексте. Результат распечатайте в виде: Буква – количество. (гласные: A, E, I, O, U)
- 27.10.2017 04:04
- Информатика
- remove_red_eye 7144
- thumb_up 67
Ответы и объяснения 1
#include
int main()
{
char c;
int A = 0, E = 0, I = 0, O = 0, U = 0;
while ((c = getchar ()) != '\n')
switch (c) {
case 'A' : {A++; continue;} ;
case 'E' : {E++; continue;} ;
case 'I' : {I++; continue;} ;
case 'O' : {O++; continue;} ;
case 'U' : U++;
}
printf ("A - %d\nE - %d\nI - %d\nO - %d\nU - %d\n", A, E, I, O, U);/p>
getchar (
- 28.10.2017 17:50
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.