Вопрос по информатике:
написать программу вывода на экран всех трехзначных чисел, кратных и 6, и 4, и заканчивающихся на цифру 8. Программу написать темя способами с использованием циклов For, While, Repeat.
ПОЖАЛУЙСТА! ОЧЕНЬ СРОЧНО!
- 07.09.2017 21:16
- Информатика
- remove_red_eye 17625
- thumb_up 106
Ответы и объяснения 1
Var i:integer;
begin
for i:=100 to 999 do if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');
end.
{While}
Var i:integer;
begin
i:=100;
while i<=999 do begin
if( if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' '); inc(i); end;
end.
{Repeat}
Var i:integer;
begin
i:=100;
repeat
begin
if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');
inc(i); end;
until i<1000;
end.
- 09.09.2017 04:06
- thumb_up 52
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.