Вопрос по информатике:
1) написать программу, вычисления значений функции Y=1/X+2 с шагом 0,1. значения аргумента беруться из [-1;1]... 2) заполнить таблицу значений функции y=sqrt(1/2x-1)+2 c шагом 0,1. значения аргумента беруться из [0;3,8]. предстоит продумать вопрос вывода результата... найти значение x, при котором функция не определена..
Трудности с пониманием предмета? Готовишься к экзаменам, ОГЭ или ЕГЭ?
Воспользуйся формой подбора репетитора и занимайся онлайн. Пробный урок - бесплатно!
- 23.07.2016 14:58
- Информатика
- remove_red_eye 19932
- thumb_up 22
Ответы и объяснения 1
program P1;
uses
crt;
var
x,y : real;
begin
clrscr;
x := -1;
writeln('----------');
while x <= 1 do
begin
y := 1/x+2;
x := x + 0.1;
writeln(y);
end;
writeln('----------');
writeln('');
x := 0;
writeln('----------');
while x <= 3.8 do
begin
if (x 0) and (1/(2*x)-1 >= 0) then
y := sqrt(1/(2*x)-1)+2 else
writeln('Pri X = ',x,' ne opredelena');
x := x + 0.1;
writeln(y);
end;
writeln('----------');
readln;
readln;
end.
- 23.07.2016 22:11
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.