Вопрос по информатике:
Напишите программу на паскале определения суммы цифр числа. Укажите является ли полученный результат четным числом.
- 14.11.2016 20:24
- Информатика
- remove_red_eye 13043
- thumb_up 75
Ответы и объяснения 1
var
a, c : integer;
begin
read (a);
c := 0;
while a > 0 do
begin
c := c + a mod 10;
a := a div 10;
end;
writeln (c);
if c mod 2 = 0 then write ('Четное') else write ('Нечетное');
end.
- 15.11.2016 06:25
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.