Вопрос по информатике:
1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.
2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!
- 08.01.2018 09:51
- Информатика
- remove_red_eye 14085
- thumb_up 75
Ответы и объяснения 1
var b,i :integer;
a:array[1..10] of integer;
begin
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do begin
if (a[i] mod 5=0) or (a[i] mod 7 =0) or (a[i] div 10=1) or (a[i] mod 10 =1) then b:=b+1;end;
writeln (b);
end.
var b,c,i :integer
a:array[1..10] of integer;
begin
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do begin
if (a[i] mod 3=0) and (a[i] mod 2 = 0) and (a[i] div 100)and (a[i] div 100=0) then begin b:=b+a[i];c:=c+1;end;end;
writeln(b/c);
end;
- 09.01.2018 07:08
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.