Вопрос по информатике:
написать программу для pascal: выиснить является ли заданное число совершенным?
- 12.04.2018 20:16
- Информатика
- remove_red_eye 7075
- thumb_up 81
Ответы и объяснения 2
Program Pr1;
uses crt;
var i,n,a:integer;
Begin
clrscr;
readln(n);
i:=1; a:=0;
while i<=n do begin
if (n mod i=0) and (in) then a:=a+i;
inc(i);
end;
if a=n then writeln('YES')
else writeln('No');
end.
- 13.04.2018 04:28
- thumb_up 48
uses
SysUtils;
var
n,m,i:integer;
begin
readln(n);
m:=0;
for i := 1 to n-1 do
if m > n then break else
if (n mod i = 0) then m:=m+i;
if m=n then writeln('Yes') else
writeln('No');
end.
- 14.04.2018 09:05
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.