Вопрос по информатике:
составить программу в паскале как изменяетс ястепень найти сумму 2^3+ 2^5 + …+ 2^9
- 21.03.2018 11:27
- Информатика
- remove_red_eye 12329
- thumb_up 93
Ответы и объяснения 1
uses crt;
function step(n:integer):integer;
var p:integer;
begin
p:=2;
repeat
p:=p*2;
n:=n-1;
until n=1;
step:=p;
end;
var
a,sum,n:integer;
begin
n:=3;
repeat
sum:=sum+step(n);
n:=n+2;
until n>9;
write(sum);
end.
- 21.03.2018 22:59
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.