Вопрос по информатике:
Даны действительные положительные числа a, b, c, которые являются длинами сторон треугольника. Напишите программу позволяющую найти радиус вписанной и описанной окружности
- 03.12.2017 03:37
- Информатика
- remove_red_eye 1457
- thumb_up 88
Ответы и объяснения 1
var
a,b,c,p,r1,r2:real;
begin
readln(a,b,c);
p:=(a+b+c)/2;
r1 := (a*b*c)/(4*sqrt(p*(p-a)*(p-b)*(p-c)));// описанная
r2 := sqrt(((p-a)*(p-b)*(p-c))/p);//вписанная
writeln(r1:1:5,' ',r2:1:5);
readln;
readln
end.
- 04.12.2017 04:53
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.