Вопрос по информатике:
составьте программу,которая заполняет массив А:[1..10] случайными целыми числами в диапазоне от 1 до 10,затем преобразовывает его,возводя в квадрат все элементы с четными индексами
- 11.08.2018 03:39
- Информатика
- remove_red_eye 5275
- thumb_up 67
Ответы и объяснения 1
Program Program1;
var
a:array [1..10] of integer;
i:integer;
begin
randomize;
Writeln('Исходный массив: ');
for i:=1 to 10 do
begin
a[i]:=random(10)+1;
writeln('a[',i,']=',a[i]);
end;
for i:=1 to 10 do
if i mod 2 = 0 then a[i]:=sqr(a[i]);
Writeln('Преобразованный массив: ');
for i:=1 to 10 do
writeln('a[',i,']=',a[i]);
end.
- 12.08.2018 04:29
- thumb_up 37
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.