Вопрос по информатике:
помогите написать программу в паскале с помощью оператора выбора(case.. of.. else) :
Напишите программу для вычисления степени введённого с клавиатуры числа. Степень в диапазоне 0 .. 9.
p.s: я начинающий в программировании, поэтому прошу попонятней написать.
- 07.08.2018 01:00
- Информатика
- remove_red_eye 17118
- thumb_up 83
Ответы и объяснения 1
var a,b,c:integer;
begin
writeln('введите число и степень'); {здесь прост программа тебя спрашивает какие числа}
read(a,b); {здесь программа читает их}
case b of {тут выполняется условие типа если b .... и идут сами степени}
0: writeln(1);
1: writeln(a); {здесь что программа выдаст если ты напишешь такую степень}
2: writeln (a*a);
3: writeln (a*a*a);
4: writeln (a*a*a*a);
5: writeln (a*a*a*a*a);
6: writeln (a*a*a*a*a*a);
7: writeln (a*a*a*a*a*a*a);
8: writeln (a*a*a*a*a*a*a*a);
9: writeln (a*a*a*a*a*a*a*a*a);
end;
end.
- 08.08.2018 05:59
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.