Вопрос по информатике:
Написать программу, которая генерирует и выводит на экран массив из 10 случайных чисел в диапазоне от -100 до 100, меняет местами первую и вторую половину массива и выводит новый массив на экран.
- 26.08.2017 20:01
- Информатика
- remove_red_eye 5936
- thumb_up 81
Ответы и объяснения 1
#include
using std::cout;
using std::endl;
#include
using std::rand;
using std::srand;
#include
using std::time;
int main()
{
int a[10];
srand(time(0));
for(int i = 0; i < 10; i++)
{
a[i] = rand() % 201 - 100;
cout << a[i] << ' ';
}
cout << endl;
int temp;
for(int i = 0; i < 5; i++)
{
temp = a[i];
a[i] = a[i + 5];
a[i + 5] = temp;
}
for(int i = 0; i < 10; i++)
{
cout << a[i] << ' ';
}
cout << endl;
return 0;
}
- 27.08.2017 16:14
- thumb_up 40
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.