Вопрос по информатике:
Составьте программу, которая формирует массив, содержащий 16 случайных вещественных чисел, принадлежащих промежутку [-2;3] и подсчитывает сумму отрицательных чисел. Вывод в столбец с двумя десятичными знаками. Только Паскаль ABC!
- 09.02.2015 23:27
- Информатика
- remove_red_eye 19404
- thumb_up 18
Ответы и объяснения 1
Program Program1;
var
i:integer;
sum:real;
a:array [1..16] of real;
begin
randomize;
for i:=1 to 16 do
begin
a[i]:=-2 + Random * 5;
writeln('a[',i,']=',a[i]:0:2);
end;
sum:=0;
for i:=1 to 16 do
if a[i]<0 then sum:=sum+a[i];
writeln('Сумма отрицательных чисел равна',sum:0:2);
end.
- 11.02.2015 11:33
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.